Please Donate
close

Only a few songs from commercials so looks like we need a new theme.....
In honor of Halloween Spooky scary songs....till the end of the month!.
Best song gets Mug or shirt to the organizer.

Tempted (Squeeze cover)

34 Views
ricktherhino
  • NeedsBacking Vocals
  • NeedsBass Electric
  • NeedsKeys Piano Electric - Rhodes
5
Published on 04 Oct 2020 / In Pop / '80s

Hit 1981 song by Squeeze. Featured in a commercial for Gap Broken-In-Jeans.

Show more
Talent Invited Reserved
Backing Vocals
Bass Electric
Keys Piano Electric - Rhodes
Please Donate
11 Comments sort Sort By

Jungle Jim
Jungle Jim 16 days ago

Hey Rick - submitted a bass part for you - lovely song to play and sounds like it really suits your voice!

   1   
dennisski
dennisski 17 days ago

I just upload a video to support area on daw adjustments. Its an older video but basic still applies. Click on support top of web page

   1   
ricktherhino
ricktherhino 17 days ago

Thanks dennisski for the info. I'll keep playing around with the DAW settings to prefect my tracks. :)

   1   
dennisski
dennisski 17 days ago

@ricktherhino: Dont forget to turn off autoscroll at the bottom. Otherwise tracks may jump around.

   1   
dennisski
dennisski 17 days ago

You always adjust in daw if you dont know the numbers. In Daw turn off auto scroll and use the drag tool on your track.

   0   
dennisski
dennisski 17 days ago

If you know what the setting is you can always just type the numbers on your track in studio

   0   
dennisski
dennisski 17 days ago

it looks like your latency was "-00.00.100". Try setting latency at "00.00.00" (no latency) In recording window you will see a latency setting. It defaults at "00.00.100". start a test collab. something where you can see the latency right away. I used yesterday by the beatles because singing starts right away. I sang just the first verse. I recorded first recording with "00.00.000",then the second recording at "00.00.050" with just BT then the third at "00.00.100" then the fourth at "00.00.150". Then figured which one was best and used that setting for any future recordings. Mine was "00.00.100" and seems most people have the same settings thats why "00.00.100"is the default.

   0   
Show more